Canon Owl BF problem

Strutter

Well-known member
Joined
Jun 2, 2001
Messages
80
Reaction score
0
Doggone camera film advance runs all the time.  If you push shutter button the advance runs.  When you open camera door to load film the advance runs.  Any ideas?  It isn't wired up yet so I am at a loss.  Friend probably doesn't have the receipt or anything now.  This is so aggravating.  Give me a big hammer.

PS: I have checked the posts for bridges and there are none.

Strutter

(Edited by Strutter at 9:41 pm on Oct. 13, 2001)


(Edited by Strutter at 10:03 am on Oct. 14, 2001)
 

Possum

Well-known member
Joined
Jul 6, 2001
Messages
721
Reaction score
0
If he knows where he got it they may exchange it for another.  Else, check the side of the camera where the door latch is.  There is a switch attached to the latch that controls the film advance when you open the door.  It normally starts when the door is closed (duh).  That sounded stupid.  Check to see if anything is impeding that mechanism from resetting when the door is opened and shut.  I can't tell you what it looks like but i know its there.  Just a thought, I know the film advance keys off this latch because I can shut the door on mine and the film advance doesn't start until I push the door latch up.

I have an OWL PF that has a door latch that is hard to open.  I have to manually push it shut when I close the door.  I don't want to take it apart because I already have it wired up and glued in.  I figure I can at least manually shut the door.  Hope you get it fixed.
 

deadcell

Well-known member
Joined
Sep 25, 2001
Messages
72
Reaction score
0
Hey Strutter, I'm curious about your camera. Did it have OWL on it somewhere or does it just say Sure Shot BF?? Thanks DC
 

Passthru

Banned
Joined
Aug 16, 2001
Messages
2,364
Reaction score
0
 When you say it isnt wired up yet do you mean that you have not modified it yet?
 If you had it apart it may be what Possum say,something may be stuck in or holding the door latch causing it to run when its not supposed to.
 Did it work fine before you started?
 
 

Possum

Well-known member
Joined
Jul 6, 2001
Messages
721
Reaction score
0
He said he checked the posts for bridges so I am assuming it was taken apart.:smile-blue
 

Strutter

Well-known member
Joined
Jun 2, 2001
Messages
80
Reaction score
0
DeadCell, It doesn't say Owl on it.  Just Canon sure shot BF.

Strutter
 

Latest Posts

Top Bottom