Friend has problem with deer cam Dc200

dmach8

Well-known member
Joined
Feb 3, 2004
Messages
944
Reaction score
0
His deer cam dc200 is eating the 9 volt batteries, they are shot in 2 days and with the 10 dollar 9 volts it lasted 4 days. Any Ideas to help him out.
Thanks, Steve
 

Killet

Well-known member
Joined
Aug 20, 2003
Messages
320
Reaction score
0
hmm, bad cam is my bet, I have a friend with one and he loves it. If the flash were stronger it would be perfect but his batteries last for several setups. We changed batteries last weekend and it had been out for 2 weeks that time and for several weeks prior to that. These are just the regular duracell batteries. Oh and he gets lots of pics off 1 set of batteries to, day and night so its definitely getting used.
 

dmach8

Well-known member
Joined
Feb 3, 2004
Messages
944
Reaction score
0
He was afraid of that it was a DC100 upgraded to a 200 due to problems last year, he put this out to cover a spot I can't till I get mine sorted out with Haymaker and it's giving him nothing but battery trouble..
Thanks for the help
 

theck

Well-known member
Joined
Dec 29, 2003
Messages
477
Reaction score
0
I had the same problem with one. I sent it back and they said it was fine. I got rid of it and started building my own.
 

dmach8

Well-known member
Joined
Feb 3, 2004
Messages
944
Reaction score
0
Until I get mine straightened out here he is skeptical about that

I'm sure haymaker will get it right and it hasn't stopped me from getting ready for #2, a sony p41 w/ Pix universal, when all arrives hope to get the pictures my cuddeback is missing, while it takes a minute to write to the card.
 

Latest Posts

Top Bottom