Owl Problems

gtk

Well-known member
Joined
Mar 27, 2001
Messages
280
Reaction score
0
Anyone having any problems with the owls ?  I have 3 owl PF's that have been working since early summer.  Here in the last few weeks I have had one Owl-PF's Led to blank out on me, and another's Flash has gone completely out.  

I have a couple of Owl's to use for parts (because of some bad soldering jobs) so I can replace the LED w/no problem.

I wonder if I can replace the flash capacitor using the parts camera ?  

Has anyone else had there owl-pf's go bad on them after they have been in service several months ?  

I am not knocking the owl-pf's.  I just purchased another last week I found on sale.  I have two of the older owl-af7's that still work fine.  They have been in service for over a year !

Thnxs.
 



Eagle Eye

Well-known member
Joined
Mar 18, 2001
Messages
170
Reaction score
0
I've got one PF that died on me. The shutter still works but it wont flash, just shows an 'H'. I've pulled the batterys and let it sit forever but I still get the same thing.
Most of the cams I build I use the older round dial version, never had a problem.
 

jayber

Well-known member
Joined
Aug 20, 2002
Messages
2,010
Reaction score
0
Just had a PF hooked up, testing (w/o film), and after it fired a couple of times the battery indicator on the camera went from full to low/dead.......with new batteries.  Not sure yet whether it's just the LED or something wrong with the camera.  Triple checked the solder connections and they all were ok.
 


Top Bottom